ORA-39142: incompatible version number 5.1 hatası

15 May by Ahmet Duruöz

ORA-39142: incompatible version number 5.1 hatası

12c r2 veritabanlarından Data Pump ile alınan bir yedeğin daha düşük , versiyondaki bir veritabanına import edilmeye çalışıldığında “ORA-39142: incompatible version number 5.1” şeklinde hata alınmaktadır.

Hata içeriği aşağıdaki gibidir.

ORA-39001: invalid argument value
ORA-39000: bad dump file specification
ORA-39142: incompatible version number 5.1 in dump file "/u01/export/ORCL.DMP"

Bu hatanın alınmaması için export alınırken expdp komutuna , import edilecek veritabanı versiyonu , VERSION parametresi ile  belirtilmelidir.

Aşağıda import edilecek veritabanlarının versiyonlarına göre , hangi version değerinin kullanılması gerektiği belirtilmiştir.

  • 10.1.0.x için VERSION=10.1
  • 10.2.0.x için VERSION=10.2
  • 11.1.0.x için VERSION=11.1
  • 11.2.0.x için VERSION=11.2
  • 12.1.0.x için VERSION=12.1

Örnek :

expdp system/****** directory=DATA_PUMP_DIR dumpfile=ORCL%U.dmp logfile=orcl_exp.log full=Y cluster=N version=11.2

 

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Lütfen captcha kodunu giriniz *

Lütfen Resimdeki Kodu Boşluğa Giriniz.