CRS-6706: Oracle Clusterware Release patch level (‘xxx’) does not match Software patch level (‘yyy’)

Oracle Grid 12.1 yada 12.2 versiyonlarında crs açılırken yama seviyelerinin farklı olmasına bağlı olarak  “CRS-6706: Oracle Clusterware Release patch level (‘xxx’) does not match Software patch level (‘yyy’)” şeklinde hata verip açılmamaktadır. Sorun genellikle yama uygulama sonrasında oluşmaktadır.

Alınan hata aşağıdakine benzer şekilde olacaktır.

[root@exadbadm01 ~]# /u01/app/12.2.0.1/grid/bin/crsctl start crs
CRS-6706: Oracle Clusterware Release patch level ('1299911088') does not match Software patch level ('1860257038'). Oracle Clusterware cannot be started.
CRS-4000: Command Start failed, or completed with errors.

Mevcut patch level bilgilerini aşağıdaki gibi sorgulayabilirsiniz.

/u01/app/12.2.0.1/grid/bin/kfod op=patches

ve 

/u01/app/12.2.0.1/grid/bin/kfod op=patchlvl

RAC ortamlardaki tüm node’larda yama seviyesi aynı olmalıdır. Problem olan node’da aşağıdaki işlemler ile sorun giderilebilir.

 

12.1 için (root ile):

<GI_HOME>/crs/install/rootcrs.sh -patch

12.2 için (root ile)

Önce

<GI_HOME>/perl/bin/perl <GI_HOME>/crs/install/rootcrs.pl -prepatch

Sonra

<GI_HOME>/perl/bin/perl <GI_HOME>/crs/install/rootcrs.pl -postpatch

 

Standalone server şeklindeki Oracle Grid Infrastructure için :
root ile

<GI_HOME>/crs/install/roothas.sh -unlock
<GI_HOME>/crs/install/roothas.sh -patch

 

 

 

Bir cevap yazın

Your email address will not be published. Required fields are marked *.

*
*

Lütfen captcha kodunu giriniz *

Lütfen Resimdeki Kodu Boşluğa Giriniz.
You may use these <abbr title="HyperText Markup Language">HTML</abbr> tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>